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1. Introduction
1.1 What is Emperor?
Emperor™ is Mecmesin’s top-range software for use with Mecmesin force and torque test
systems. With it, you will write test programs to control test stands through test
sequences, gather detailed data from those tests, apply calculations to analyse the data,
present the results, and deliver them, and/or the raw data, to other destinations.

1.2 Using this manual
The purpose of this manual is to get you up and running quickly by taking you through:
• installing the software and adding users
• configuring the system for the way you want to work
• understanding the testing environment
• configuring the test environment preferences and defaults
• configuring report and data export templates
• compiling and running test programs
• adding calculations
The appendices provide background information and explanations.
The following stylistic conventions are used in the text:
Onscreen Button or keyboard character to press.
Program Set-up > Calculations for directions via a sequence of menu options.
[Report Templates] for the tab name for a particular page of settings.
‘Graph Title’ for the name of a data entry field/box.
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2. Setting-up the Emperor Software
2.1 Your system
A Mecmesin force or torque testing system comprises:
• Emperor™ control, data acquisition and analysis software on a PC
• a motorised test stand connected via USB to, and controlled by, the PC
• an intelligent loadcell (ILC) or torque cell (ITC) mounted on the test stand, which
communicates with the Emperor software.
This manual covers the Emperor software. A separate Assembly and Installation guide
covers the operation of test stands and loadcells, and a Guide to Safe Use of Mains Powered
Test Stands must be referred to before operating any Mecmesin test system.
The minimum specification for the PC or laptop to be used is 2 GB RAM and 60 GB free
space on the hard drive, running Windows™ XP Pro with SP1, or above. A CD drive is
required for installation. At least one USB port or one RS232 port are required for
attaching to the system.
Note: Emperor software is not available for Linux or Apple Macintosh operating systems.

2.2 Installing the Emperor software
2.2.1 Access to data folders
Emperor requires access to certain folders listed below. Before installing the program,
please make sure that read and write access is granted for these folders. In particular, if
the computer is part of a centrally-controlled Windows Domain system, it may be
necessary to consult with your IT department to allow correct access to these locations.
Windows XP : User Data location
Emperor Force

C:\Documents and Settings\All Users\Application Data\Mecmesin\Emperor\Force

Emperor Torque

C:\Documents and Settings\All Users\Application Data\Mecmesin\Emperor\Torque

Windows Vista or Windows 7 : User Data location
Emperor Force

C:\ProgramData\Mecmesin\Emperor\Force

Emperor Torque

C:\ProgramData\Mecmesin\Emperor\Torque

All Windows versions : Program files location
Emperor Force

C:\Program Files (x86)\Emperor\Force

Emperor Torque

C:\Program Files (x86)\Emperor\Torque
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2.3 Install from CD
Place the Emperor CD in the CD drive and close it. Emperor should start automatically and
ask if you wish to proceed with the installation of the software. If not, and you see a
permissions alert, you may need instead to right click the Setup file in File Explorer, and
select ‘Run as administrator’.
If the installation program does not start automatically:
• On your computer desktop, click on the shortcut to ‘My Computer’
• Click on the CD drive that contains the Emperor software CD
• Navigate to the \Emperor folder
• Double click the ‘Setup.exe’ file
The InstallShield Wizard will now take you through the process with a series of prompts:
• When prompted to continue, click Next >
• Accept the terms of the license agreement.
• Select the language you need to have installed, or all languages.
Emperor will now be installed on the PC. When complete, remove the CD from the drive
and store in a safe place.

2.4 Running the software
Before running the Emperor control software, your PC should be connected to a test
stand with an appropriate ILC/ITC connected to it, and switched on. Before it loads,
Emperor will check the following.
Is the PC is connected to a test stand, switched on, and with an ILC/ITC connected to
the test stand?
If not, a warning message is given. Using the OK button will still allow the software to
load, but in ‘limited functionality’ mode. Any further attempt to address the test stand
will produce an appropriate warning message, so while existing test data can be
inspected and processed, new test data cannot be accumulated.
Does the loadcell match the software?
Loading Emperor Force with a Torque stand attached, or Emperor Torque with a Force
stand results in a warning message, and the OK button will close Emperor.
Is the ILC/ITC still in calibration?
If the calibration for the attached loadcell has expired, a message will recommend that
you contact Mecmesin or your authorised distributor.
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Is a significant (20% of loadcell capacity) residual load being registered by the ILC/ITC?
If a power failure occurs, or a system has been switched off whilst still under load, a
warning message will ask how you want to respond (using either the software or
hardware direction buttons). Click Yes to tare the load (display zero) or No to leave the
current load reading; either will allow the software to continue loading.

Is the test stand reporting an unresolved fault condition?
Any other fault within the test stand will produce a message advising the operator to
contact their Mecmesin agent.
When starting up, Emperor will also advise the operator if:
• an ILC/ITC is detected that has not previously been connected to the system. Emperor
will then update its database of available loadcells.
• the capacity of the connected loadcell is less than the current software ‘maximum load’
setting. Emperor will automatically reduce this setting to the capacity of the loadcell.

2.5 Logging on as a user
Emperor initially loads a ‘splash screen’ showing the software version, and boxes for
entry of a valid Operator name and Password. Emperor has two levels of user, Master
and Operator. The current operator can be identified in test results and data files.
Masters have full access to all parts of the Emperor program, including creating new
users, and may create as many new masters and operators as required.
Operators have access that can be restricted to certain parts of the system, to prevent
accidental changes to settings and programs.
Until you set up your own user accounts, you will need to use the installed default
usernames and passwords. These are case sensitive:
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Status

User name

Password

Operator

operator

operator

Master

supervisor

supervisor
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3. Console Mode
When you log on to Emperor, you are given a choice of operating mode:

Normally you will use Programmed Testing, but Console Mode has been designed for
routine operation of repeated standard tests by operators who will require minimal
training. Programs to run under Console Mode can be written in this mode, or as a full
program under Programmed Testing and then run in this mode.
Console Mode drives the Mecmesin-xt range of testers using their side-arm touch-screen
tablets, and the documentation for this mode can be found in the manual Emperor™
Programming for Mecmesin xt Force and Torque Test Systems (431-389). Operation is
described in terms of the touch-screen, but the keyboard and mouse may be used as
normal. Opening and closing Console Mode is within Emperor, so the logon and
shutdown procedures for –xt do not apply.
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4. System Settings
4.1 Adding new operators and master user accounts
Log on as a master user and go to the top level menu: Setup > System > [User accounts].
To create a new user, add the user details of name (alphanumeric, no spaces), password
and type, then click Add .
To remove a user, select the user on the left and click Remove .
You cannot delete all Master user accounts, one must remain for full access. By all
means rename the ‘supervisor’ account more securely, but add other master users by
name.
To change the profile of a user, first select the name on the left, make the required
changes, then click Change .
Automatically log on this user: If there is mainly one user, running mainly one test in
Console mode, you can set Emperor to automatically open with this user account and
optionally, with a Favourite test program. To operate differently, all that is required is to
Log out (File menu), and you will be returned to the normal splash screen to log on as a
different user and with no default test program. (‘Query operating mode’ means ask the
user when they log on.)

JaneS is being added as an Operator, using the Favourite 1 program, in console mode, with restricted
capabilities
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Automatically Run Selected Console Program on Start Up
In Console mode, the five most-used ‘Favourite’ programs can be allocated to singlebutton running. If one of these favourites is also chosen from the drop-down list as the
default program, the user’s operating mode must also be set to Console mode.
To change the automatically logged-on user, login as a Master user, select their name
from the list on the left, then uncheck the automatic setting and then click Change .
Some system settings are important for initial installation and use. Others, such as data
export schemes, reporting templates, and system deflection you will return to as your
testing requirements evolve, but it is important to know about them from the start. think
of System Settings as resources for different test scenarios.

4.2 Connecting to the test stand
Emperor must be set up for operation with the attached stand and load/torque cell.

Setup Menu: System settings for communicating with hardware

The drop-down list against ‘Test Stand Input Port’ will include the PC port to which you
have connected the stand. If you are unsure which port to select, your IT department
should be able to advise.
You can also set up a port for data export here in the same way. This is only required if
you need to stream data to an external device.
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4.3 System Deflection Compensation (SDC)
Under high loads, a very small element of measured displacement may be due to flexing
within the system (test stand, loadcell and fixtures) rather than in the sample under test.
The force to create a given displacement may therefore be slightly over-indicated. This
system deflection can be measured and compensated for. It can be important where
deflection in the sample is similar in magnitude to that in the system, and where very
accurate readings are required. SDC is mainly used in top-load testing.

Emperor can store compensation data from different combinations of gripping
accessories (called ‘Groups’) for different loadcells, and apply it to the setup in use.
To indicate if a sample has been measured with SDC turned on, add an INFORMATION
command to the calculations, which will show the SDC status in the results.

4.3.1 SDC Groups and Systems
System Deflection Compensation becomes available once you have performed a
calibration for each Group and System for which you want to use compensated results:
• A Group is a fixing assembly, which might be as simple as a compression plate and
the anvil plate, or could be any combination of different gripping accessories fixed to
the loadcell and the anvil plate. A Group can be used with several stand and loadcell
combinations.
• A System is the combination of the test stand and a loadcell. In practice you might
have one stand, with perhaps two or three loadcells. Each combination of test stand
and loadcell is a different System.
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Examples:
Group

System

50mm compression plate

Mt 1-i Stand, serial No. 10-1015-01
ILC 500N, serial No. 10-2056-10
Mt 1-i Stand, serial No. 10-1015-01
ILC 1000N, serial No. 10-1080-20

Small Single-action vice plus multi-jaw grip

Mt 1-i Stand, serial No. 10-1015-01
ILC 200N, serial No. 10-1945-10
Mt 2.5-i Stand, serial No. 10-1020-01
ILC 500N, serial No. 10-2056-10

Creating an SDC data file
• Attach the required stand accessories (grips, plate, probe) without a sample. For force
stands requiring compensation corrections in the compression direction, place the
compression plate or probe very close to the anvil.
• Go to Setup > System > [System Deflection Compensation] tab and click Run . This will
introduce the built-in SDC program by requesting the direction of the test.
• If a previous file exists, you will be asked to Save or Discard. Click Discard . There
may then be advisory alerts regarding adjusting certain parameters to the stand.
Click OK for these.
• At the graph display, click Start to run the SDC test.
At this point, alerts are given to ensure you have assembled the SDC Group correctly.
• When prompted, add the maximum load in newtons up to which to test.
The SDC test will now run, with progress alerts indicating a bedding-in run to 90 per cent
of the maximum load, followed by a second run to 95 per cent. The test will end with
confirmation that the file has been saved.
• Return to Setup > System > [System Deflection Compensation] tab.
You will now create a Group relating to the accessories used.
• Click New Group to name and create a new compensation Group (e.g. 50 mm
compression plate):
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• Now add the System (test stand and loadcell):

• Click Get File to access the System Deflect folder, and select the appropriate file (as
just saved) for the direction of the SDC test, then click Add to complete the SDC
setting:
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SDC for 50 mm compression plate attached to loadcell 12-0240-08 on stand serial no. 12-1010-03

Using an SDC data file
To use the compensation data when writing a test program, tick the ‘System Deflection
Compensation’ check-box in Setup > Preferences > [General] tab. All preference settings
are stored with the test program library file. The relevant Available Groups for the
direction of the test will be displayed in the drop-down box—choose the group you
require.
Note: Emperor always knows which test stand and loadcell (System) are in use, but
cannot automatically identify which fixing accessories (Group) are attached. It is
important to check that the SDC Group selected matches the accessories fitted.
When adding results to a file where SDC has been used, the same stand, loadcell and
fixtures must be used.

4.4 Setting file locations
You can leave the default file locations for these files (which will depend on your
version of Windows), or allocate a different or networked location.
Change any file location, click OK and log off and on again for the change to take effect.
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4.5 Using and creating data schemes
Data schemes are templates defining how results data are arranged for export. Data may
be exported as raw data (all data points recorded) or as results (profile by sample). There
are default templates available, but you can create and name schemes of your own.
To begin with you don’t need to do anything; read through and come back here when
you start to export real data. Use the defaults at first and then decide how you need to
create your own schemes.
Choose to create a scheme for either Results or Raw Data , and select New Scheme from
the drop-down list, then enter a name and confirm with OK .
Now profile what you require for the Scheme and click Update to save.
Results:
Sample Orientation

Arrange samples in rows or columns

Display Options

Include headers for results, samples and display units

Statistics Output Options Include the statistical information you require
Overall Result
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Show ‘Pass’ and ‘Fail’ against combined criteria for all
verified calculations. Hidden results are those results used in
calculations that have been chosen not to be displayed (see
Appendix D, A Note on Overall Result and Hidden Results).
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Raw Data:
Header Options

Include those header elements you require.

Display Options

Choose which elements to include (e.g. HHHH or distance
may not both be important). Choose also the order in which
data are exported (column sequence). This applies also to
Excel exports, where Excel is used for further graphical
presentation and column sequence will matter. To re-order,
select an item and use the  and  arrow buttons to move
it up or down.

Emperor Force and Torque Operator Manual

Mecmesin  13

Output Data as

‘Original’ data is without display options, whereas
‘Displayed’ might include Preferences such as accumulative
displacement under graph settings.

4.6 Report templates
Report templates enable you to customise the layout of printed reports of results. You can
define two logos, headers and footers, the layout of the data itself, and whether to include
a graph.
To begin with you don’t need to do anything; read through and come back here when
you start to report real data. Use the default template at first and then decide how you
need to create your own templates for different tests.

4.6.1 Add or edit a report template
You can edit a report template or add your own. You might prefer to leave the Mecmesin
default template as a permanent reference.
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Add and name your template (or select a name and Edit ) to bring up the Report
Template Wizard.

Logos
The first option is to add logos top left and top right. You might choose to use your own
along with that or a client or product. Double click either logo box for a Windows
browser to list your images, which must be stored in the file location for Logos, as set in
the Set-up > System > [File Locations] tab. Any images you use must be in bitmap format.
You may need to resize images to avoid very large files.
No bitmap?
You can open any image you have in Windows Paint (in Windows, Accessories—or
right click the file name in Windows Explorer and choose Open With > Paint), and Save
As a 24-bit bitmap into the Logos file location.
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Note: Images cannot be linked from anywhere other than the defined File Location for
Logos (see 4.4, Setting file locations).
Remember to Save and Exit before you leave the Wizard.
Headers and Footers
Headers and Footers both work in the same way. Available elements are listed in the box
at the top, and the two boxes below represent left and right print areas. The content for
each of these items is added before a test is run and the results saved, under Test > Notes.
Select each item you want to include and use the  down arrow above the respective
box to add it.
To move an item out of the used list, back into the available list, select the item and use
the  up arrow.
To change the order of header or footer contents, left or right, select the item and use
the  and  arrows to the right of the box.

Remember to Save and Exit before you leave the Wizard.
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Results
The title of your template now shows top left. You may now decide what you want to
appear as a heading for the results section, what to include, and how to lay it out:

Note that if you choose to include bad samples, these will be listed in report results, so
you may want to include a calculation line INFORMATION, showing ‘Bad sample
reason’.
Remember to Save and Exit before you leave the Wizard.
Graphs
This option simply allows you to choose whether to include a graph or not, and to give it
a report section heading.
Printing
Report templates only define content, not final appearance. More often than not, a
landscape paper orientation is required. This is set in File > Print Set-up.

4.6.2 Deleting a report template
To completely remove a report template, navigate to the Emperor data files and the
\Templates folder, and locate the .xml file with the appropriate template name, for
deletion.
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5. The Programmed Testing Environment
5.1 Menus
5.1.1 File menu
New

Opens a new, empty, program file. Any other file currently open
will be closed with appropriate warnings to save.

Open

Opens the last used folder for Results files (.for). Library
Programs (.lif) are not ‘opened’, but ‘loaded’.

Save

Saves the current results file, if changed.

Save As

Saves the current results to a new file name. Here you are
invited also to manage file size by selecting ‘Individual’ samples
or ‘All the same’, to Compress, Cut or Crop the data (See
Appendix C.2, Managing File Size).

Load Library Program Loads a test program, ready to run.
Save Library Program Saves an edited program, with a prompt about overwriting the
original Yes or creating a new file No .
Print Setup
18  Mecmesin

Select your printer, and print options, including paper orientation.
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Print Report

Prints these results using the embedded report template.

Print Report Preview

Examine your results report before printing.

Print Graph

Just prints the currently displayed graph. Check your paper
orientation in Print Setup: landscape may be more useful.

Export

Exports raw data results with options (below), when enabled for
these results and a filename specified, in Setup > Report and Data
Export > [Raw Data Export]

Transmit options are greyed out because Setup > Report and Data
Export > [Transmission] options have not been enabled for these
results.
Note: To export results only (see 7.2, Results Data Export):
1. Setup > Reporting and Data Export > [Results Data Export]
2. add the file name you want (or leave blank for a default
name)
3. add the required samples to the results
4. click OK or Update to File and the file is automatically
created (not by Export from the File menu)
Send to Excel

Exports raw data and/or results to Excel, with options (below),
when enabled, in Setup > Report and Data Export > [Excel]
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This example shows both results and raw data have been
enabled. Remember that Excel has limits on its number of rows
and columns that raw data can easily exceed. You may choose to
cut or crop data in the Setup choices (see 7.3, Raw Data Export).
Recent Results Files

Links to the six most recent results files to have been used.

Recent Library Files

Links to the six most recent test programs to have been loaded.

Logout

Returns you to the Emperor splash (logon) screen.

Exit

Logs off and closes the Emperor software.

5.1.2 Test menu
Notes

Notes may be added to, and saved with, a results file and used
in a report template.

The date shown is that of the last edit of the Notes. For the notes
in the right-hand column, see Section 6.9, Custom Notes.
Program

Write (File > New) or edit (File > Load Library Program) a test
program. If a results file is open, you can edit the underlying
program but must save any new results to a new file.
See Section 8, Writing an Emperor Test Program.

Calculations

Add calculations to the data to produce results to evaluate
and/or display. See Section 9, Test Calculations.

Results

Displays results one sample at a time, with print options
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5.1.3 Display menu
Graph

Adds the Graph Toolbar (see page 28) for analysis and removes
onscreen controls.

Settings

Displays the Setup > Preferences > [Graph Settings tab]. (See
Section 6.4, Graph Settings.)

Overlays

For visual comparison, overlaying graph traces can be very
useful. Overlay multiple traces from samples tested, or compare
a trace with a reference file for tolerance (see Appendix:
Tolerance Bands). Available to Master users only.
By shifting the horizontal axis for each plot, the lines can be
separated in order to distinguish them better. Here an offset of 5
axis units (seconds, mm, etc.) is being set (Display > Overlays):
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Compare the two examples below, the first without offset, the
second with a 5 mm offset. (Taken from bevcan.for example
results file, installed with the Emperor software.)
How offsets are displayed
• Every selected sample in the results file is assigned a
sequential offset position. (In this example, Sample 6 is
unselected).
• The current selected sample (displayed red) is copied out of
its assigned offset position into the correct original axis
position. In this way cursor snap can be applied and true
values for any feature can be read.
Displayed samples

Offset position

Sample 1

1

Sample 2 (selected)

0&2

Sample 3

3

Sample 4

4

Sample 5

5

Sample 7

6

No overlay offset, all samples except 6 displayed:
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Overlay offset, Sample 2 (blue) selected and also in (red) zero-offset display position,
x-axis extended:

Any sample trace can also be compared against a reference file
for tolerance (see Appendix: Tolerance Bands). Available to
Master users only.
Data

Displays the data from a single sample, up to the first 32,000
points. These may be selected and copied and pasted into Excel.
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Replay

Presents the graph axes and an x-axis slider. This can be dragged
across to ‘replay’ the graph trace whilst displaying Load,
Displacement, Time and Events.

Copy Graph

In Display > Graph mode, this will copy the graph as an image to
paste into a document elsewhere.

Interrogate

For Cursor Drop, Time Line, Review Results, see Graph Toolbar
on page 28.

Summary View

Displays or hides the results panel above the graph.

Toolbars

You may choose not to display either the Standard, or the
Load/Displacement (Angle) toolbar.

Status Bar

You may choose not to display the Status bar, which carries
information on test mode, load, data rate, program line or cycle
no., sample no., and cursor x/y co-ordinates.

5.1.4 Setup menu
Preferences
See Section 6, Preferences
System
See Section 4, System Settings
Language
Choose from the list of installed languages. Requires a restart of Emperor.
Report and Data Export
See Section 7, Reports and Data Export.

5.1.5 Tools menu
Service
As a troubleshooting aid, your distributor may ask you to run Tools > Service > Diagnostic
Report. Tick to include the program and calculation details in the dialog box and save the
diagnostic report to your PC desktop. Send this to them as an email attachment.
You may be asked by Mecmesin or your distributor to Upgrade firmware using a
supplied file, with instructions.
Other update options may be recommended, again using distributor-supplied files.
Stand configuration provides information about your test stand and the currently
attached loadcell, including its calibration dates, overload events, serial number etc.:
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Reconnect
If the stand for any reason (e.g. overload) goes into ‘limited functionality’ the stand and
cell have been protected by being disconnected. Remedy the situation using the stand
controls and decide how to avoid the situation again, then use the Reconnect command to
restore full functionality.
Recalculate Results
In most cases, when calculations are changed, you will be prompted and you will choose
to recalculate results straight away, but recalculation can be done later or at any time by
using this option.

5.1.6 Help

Help Topics raises the Emperor help file (based on this manual).
Email provides the appropriate address to seek technical advice from Mecmesin.
About provides version and contact information:
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5.2 Test run area
The programming test screen for Emperor Force (upper) and Torque (lower, populated):
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The Programmed Testing screen can be used to control stand movement while a program
is not running.
The stop button replicates the physical stop button. Note: Esc and Space also stop the
crosshead.
The jog controls replicate the physical controls. Jog Speed is set to either Fixed (specify)
or Variable in Setup > Preferences > [General].
Note:
• on a disconnected test stand, the front panel jog buttons will move the crosshead (force)
or platen (torque) a small amount at a time
• once connected, the crosshead or platen will move continuously to the front panel
buttons
• when Jog Speed is set to Variable, the onscreen buttons are used to accelerate or
decelerate the crosshead or platen incrementally, direction only changing at zero speed.

5.3 The Emperor toolbars

Toolbar buttons and segments are available or greyed out according to relevance. Here,
for clarity, all are shown as available. Many are duplicated on the drop-down menus (e.g.
File > Open is the first button) but also here for ease of use. Hover over a button to see its
name.
The complete toolbar is in segments, with buttons for:
• managing the editing of programs and notes, handling results and files and help
• working through sample results and editing samples out
• setting baseline (zero point) parameters of the test stand and loadcell.
Program and results tools (Standard toolbar)

Left to right:
• New (also File > New, or Ctrl+n) gives a ‘blank canvas’ for writing programs.
• Open (also File > Open, or Ctrl+o) opens results files.
• Save (also File > Save, or Ctrl+s) saves results files.
Note: to load and save Library (program) files, use the File menu.
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• Copy Graph is activated with the Graph Analysis Mode button (see below).
• The printer icon (File > Print Report) will send your results to print according to the
default report preferences and default report template, or as amended under Set-up >
Report and Data Export.
• Use the adjacent Report Preview button to see how your printout will look.
Printing note
On the screen graph display, the current selected sample trace is always picked out in red
for clarity. When printing, red is not used. The first sample trace is restored to black.
You may need to adjust your printer preferences as well for colour, orientation and
margins.
• The standard Excel button and the adjacent Export Data button (for raw data only)
become available when respective export destinations are defined in Set-up > Report
and Data Export.
Graph Analysis Mode adds the Graph toolbar:

ways

Graph Settings (also Display > Settings) allow the graph to be viewed in different

Zoom allows you to drag a marquee with the mouse to select an area to examine in
close-up. Click the button again to return to normal view.
Cursor Drop (also Display > Interrogate > Cursor Drop) allows you to click on a data
point, then click on a second position to drop in a text box with the co-ordinates. Right
click the box to add a caption, move or delete the box.
Note: Cursor drop features cannot be saved, only used to annotate an immediate
printout.
The Timeline button (also Display > Interrogate > Timeline) adds an x-axis slider or
sliders below the graph. (See illustration below.) This draws a vertical line for an accurate
observation of the x-axis for an event along the current selected sample (always shown as
a red line).
Review Results (also Display > Interrogate > Review Results) allows you to click on
any calculation cell for a given sample in the results panel, and see the position of this
calculated value as a point, line or area on the graph. This allows the refinement of
calculation values, such as limits, in line with the actual behaviour of test samples. In the
case of limits, these may be repositioned with the slider controls beneath the graph to
change the calculation values in the test program (not the test library file), which can then be
saved.
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Note that in Graph Analysis Mode, the cursor position in the graph is shown dynamically
as coordinates in the Load, Displacement/Angle or Time boxes, and that a graph image
can be copied to the Windows clipboard (right-click, Copy Graph).
The following illustrates Review Results, with Sample 5 selected, and ‘Peak load 2’
clicked to show the marker on the chart within the data range set by the sliders. Note the two
sliders below the chart. This data range will be retained as the calculation limits in the
results file.

Replay
This button switches on test replay mode, with the corresponding control toolbar:
Play, Fast forward and Return to start, or pause (the Stop button). Alternatively,
below the graph, there is a slider to progress through the test. This enables you to
examine the course of a test in detail. Use Exit Replay, or click the Replay button to
resume normal graph view.
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Results
Click the Results button to view all results lines per sample, print any or all. Note:
this sends results straight to the designated printer without any further print dialog.
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Sample tools (Specimen toolbar)

The down and up arrows take you to previous and next sample, the ? allows you to select
a sample by number:

The basket button will delete the sample, i.e. remove the data. (This is a permission that
has to be given explicitly to an operator in their profile.)
Test stand tools (Load/Displacement[Angle] toolbar)
This toolbar is useful for manipulating the test system and setting up tests. Most test
programs will incorporate some or all of these actions as program commands.
(See also Appendix: Relative and Absolute Positions: Zero, Home and Start.)

Zero Load: this will set (tare) the current load reading to zero.
Restore Load: this will reset the current load reading to its true value.
Zero Displacement/Angle: this button will set (tare) the current crosshead/platen
position to zero.
Home: this will return the crosshead to the Home position (relative to either last tare
or to Absolute Zero as set in Preferences).
Set absolute zero: in relation to the current position, set Absolute Zero (stored in the
system firmware, not in the software, so available after switching off and on again.)
Display absolute position: after zeroing displacement, this will restore the display
to show current displacement from Absolute Zero.
Remember, when you are changing fixtures of different dimensions, that Absolute Zero
is stored in the test stand firmware, not the test program or software.
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6. Preferences
Preferences are all about how your system behaves when running a test, and these
parameters can only be edited by Master users, under Set-up > Preferences.
Preferences include:
Control
• direction of travel of the stand crosshead (force) or platen (torque)
• jog speed under software control
• crosshead/platen starting position
• limits for load, displacement, angle, time and speed
• setting the digital inputs and outputs from the test stand
Measurement
• profiling data acquisition rate and triggers from the loadcell
• choice of units for force, displacement, angle and time
Results
• settings for the display of results and graphs.

6.1 Default settings
As Emperor arrives ‘out of the box’, there are default settings, but your requirements may
well be different, so you can edit and save your own default set of most common
preferences. The parameters set in the Preference tabs will be the settings used for the
current activity, and may be saved as default settings: Save as Defaults . These new
defaults are the values to which Restore Defaults will go (i.e. not ‘factory settings’).

6.2 Test program settings
From those defaults, you can make further changes as required for writing a test
program. These preferences will then be saved with the program without changing the
defaults, so each program retains its own set of preferences. Use OK to save.
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6.3 General preferences

General preferences for Emperor force, above, and below, Emperor torque
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Direction of travel (tension/compression : clockwise/anticlockwise)
Your default preferences are set for one direction of travel. If your most common use is
for either compression or tension (force tests) or clockwise or anticlockwise, make this
your default. Note that all values here are entered as positive in relation to this direction.
Positive values in programs or results, represent application in the named direction and
negative values in programs or results represent release or reverse. See page 76,
Direction of Speed, Force and Displacement.
As far as an operator or observer of the system is concerned, though, when a torque
system rotates clockwise or a force system compresses, this is a positive operational
direction, and anticlockwise or tension represents a negative direction. Jog buttons
therefore always do what they say.
Units
Select the appropriate units from:
Units

Force

Torque

Force/torque

kN, N, mN,
kgf, gf,
lbf, ozf,
MPa, kPa, psi, N/mm2

mN.m, N.cm, N.m,
gf.cm, kgf.cm,
lbf.ft, lbf.in, ozf.in

Displacement

mm, in
If ‘Use %’ is selected, an
original length of the sample
must be entered.

rev, deg

Time

h, min, sec

h, min, sec

Scaling for other units such as radians or non-SI units is best done across a whole data file
in Excel after export, rather than factoring each result by calculation within Emperor.
Use %

In Emperor Force, ticking this check-box and entering the
length of the specimen below, in ‘Specimen Original length’,
allows the option of displaying the graph as ‘% displacement’
(% elongation).

Specimen (Force sample)
When using pascals or psi stress units, you must add the cross-sectional area of the
sample (diameter, or width and depth) before preferences can be saved.
What happens if you view test results on a different PC?
Units of measurement remain as recorded, even if viewed with Emperor on a PC with
different default units. The second user can, if they wish, edit the results to read in
other compatible units, and resave the file.
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Limits
Your system is protected from overloads such that the loadcell capacity and stand load
rating, whichever is the lesser, will be detected and the system will always stop with a
warning that an overload has been reached. Similarly, the limit switches on a MultiTest
force stand (see your Assembly and Installation guide) prevent travel beyond physical
limits.
However, for reasons of safety, sample protection, or run-on, you may well want to set
lower maximum values for load, displacement/angle, time or speed. Again, these can be
set as system defaults, or per test program.
Note: in Console Mode > Test Programs, these are called ‘Local limits’.
Home Position
The crosshead or platen can be sent to a ‘Home’ position. This can be in relation to a set
absolute zero position (angle or height), so Home itself becomes an absolute position,
which is retained when the test stand is switched off.
Alternatively, Home can be a position that is relative to another (e.g. 15 mm above a
standard test sample height—when set as zero displacement—to provide clearance for
insertion or removal). This position from ‘tared zero position’ depends on where and
when displacement is zeroed, which includes being done in a test program.
This preference setting is either used for your defaults, or set when writing a test
program to define the home position at the start.
Reverse to nearest

(torque) When a torque platen is returning to its Home, it can
either reverse by the total amount of rotation in the test
(perhaps several rotations) or, by preference, only as much of
one rotation as required to reach the home-defined angle
(defined as either relative or absolute).

Jog Speed
This option sets the speed of travel for the crosshead/platen from the PC only. It does not
affect the stand front panel controls.
Variable speed

means that for each click of the  or  button, speed in that
direction will increase in increments to 5, 10, 25, 50, 100, 250,
500, 750 and 1000 mm/s, and that the opposite arrow will not
reverse, but decrease the speed incrementally.

Fixed speed

means that each jog button starts movement at a value you
decide, and the opposite button stops movement on the first
click, and reverses direction on the second click, at the same
speed.

General
Autosave

ensures that results files are saved after each test, as protection
against data loss in the event of power interruptions.
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Filename Format

You can, if you choose, incorporate system information in
autosave file formats. As well as system Time and Date stamps,
and the logged-in operator name, four items from the Test >
Notes option may be included (Test name, Specimen, Batch,
Customer Name):

Choose only the most relevant items be used, since file names
can become unnecessarily long. Notes data is retained in the
results files in any case. This can be saved as a default for all
autosaves, or just for the current test. Restore Default returns
to the last Save As Default settings, not to a ‘factory settings’.
Use old KINK …

allows for backward compatibility with the old KINK
calculation method that was used in Emperor before version
1.17.

System Deflection Compensation (SDC)
See Section 4.3 for a full description of creating SDC files. SDC compensates for the very
small deformations within a complete test system itself (stand, fixtures and loadcell)
when under high load.

6.4 Graph Settings
This tab is used to set the options for how the results will be presented graphically. Use
the radio buttons and drop-down boxes to choose the graph axes. This tab is also
available under Display > Preferences so that operators who have also been granted
permission to alter Graph Settings, have access for individual tests.
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Emperor Force

Display accumulative displacement. Ticking the check box
will plot the displacement on the graph from the beginning of
the test, i.e. displacement will be shown as increasing
regardless of the direction of travel of the crosshead. This is
useful when calculating area, average and slope, and in cyclic
tests.

Emperor Torque

Display accumulative angle can be used to show the total
angle, regardless of the direction of travel or rotation, beyond
360 degrees.

Graph title

is optional. The X and Y axis titles will be filled in according to
the radio button selected, but you can overwrite these if
preferred.

Legends

for multi-trace graphs, can be added as required.

Gridlines and scale

Check to display gridlines.

Auto scale

When a test is running, the graph is auto-ranging—it will be redrawn so that the trace is always visible. Ticking the Auto scale
check box will cause the graph to be re-drawn at the end of the
test with the axes scaled to display all the data collected (and
the min/max settings here will be greyed out).
If you un-tick the Auto Scale check box, the greyed-out boxes
become available and you can manually enter the X and Y axes
maximum and minimum scales. At the end of the test, the
graph will be re-drawn using these scales.
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Markers

adds a marker for every data point, which can be useful when
zooming in on a trace.

Cursor snap

will make the cursor snap to the nearest data point, which
makes visually obtaining exact co-ordinates easier.

6.5 Automate

These preferences take place on completion of a successful test.
Stop

the crosshead stops

Return to Home

the crosshead returns to the Home position, but without
recording the return travel on the graph. (For clarification of
positions, see page 74, Relative and Absolute Positions:
Zero, Home and Start.)

Ignore information messages
During an automated process, information messages may not be required or useful.
Delete sample(s) after automatic export
If you are automatically exporting data after test completion, instead of saving them in a
results file, you can also automatically delete the sample data. Note: deleted samples
cannot be recovered.
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6.6 Results Display
In the results display panel above the test/graph area (Display > Summary View), Results
can be seen, by default, one sample at a time or all at once, by choosing between ‘Current
Sample’ and ‘All Samples’. This default does not prevent any or all samples being
viewed, only that if a large number of samples is usual, the statistical averages may all
that are required.

Tick any of: mean; standard deviation; minimum; maximum; to be displayed to the right
of the result(s). By default, only the first two: ‘Display Mean’ and ‘Display Standard
Deviation’ are ticked.
Display Overall Result

Overall result is the accumulated pass/fail assessments of all
verified and included calculations. If only one verified
calculation is crucial for pass/fail and others merely indicative,
then the overall result may not be needed.

Include Hidden Results Hidden results are usually hidden for a reason, but if some are
verified, this can make an overall result appear confusing.
Showing them can clarify this.
For Overall and Hidden results, see Appendix D: A Note on Overall Result and Hidden
Results.
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6.7 Data Acquisition
To obtain more detail from that part of a test that is of most interest, Emperor allows you
to optimise your data acquisition.

Sampling Rate

Select, in data points per second. Faster is not always better.

Triggers

Acquire data during the most relevant portion of a test, if
known, by time, load or position (change in
displacement/angle). Data acquisition will begin at the first
trigger point, and will continue to the second value of that
trigger, or until another trigger end point is reached, or until
the test stops, whichever is reached first.

Data Capture Window

This sets the duration of a moving window during which data
are collected. Example: a window of 60 seconds initially fills,
and as subsequent data points are acquired, the earliest are
dropped, so wherever the window stops, the last 60 seconds of
data are retained.

6.8 Digital I/O
Mecmesin test stands have the facility for six digital inputs and six digital outputs that
can be used to integrate the test stand with programmable logic controllers (PLCs) or
other equipment. See Appendix F: Digital Input Commands and Output Notifications for
details.
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Select the Input or Output line, use the drop-down options bar to select the action, then
click Update .

Digital inputs then can be used in test programs so that foot switches (for example) can be
used. They can also be used to automatically suspend and restart data acquisition
periodically on a many-cycle repetitive test of a sample.
Start and Stop data acquisition, as all I/O commands, can be used as many times as
required, e.g. every time a foot switch is deployed—or triggered by cycle counts to
capture spot values over many cycles. Optimal use of this feature requires use of the
Digital I/O Simulator Plug (part no. 432-663), enabling much more sophisticated and
selective cyclic routines to be created (see datasheet DS-1156).

6.9 Custom Notes
Custom Notes enables you to name five user-defined notes fields, stored with a program.

Emperor Force and Torque Operator Manual

Mecmesin  41

If you choose to use the Custom Notes feature, all five titles must have at least one
character in them. Enable only those you wish to use by default, and enable them
differently for each program if required. In the above example, a dash has been placed in
the last two, since only three Custom Notes are required, and only the three titled notes
have been enabled.
If you wish to save these as your default notes definitions, they will be presented as titles
in a new program’s Custom Notes, in the right-hand column, with an active field where
also enabled:
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‘Enabled’ means that the titled field will:
• be available to be used when a test is run
• appear in a report template that includes that custom note number (in the example
above, ‘Batch no.’ is Custom Note 3)
• feature in results data sent to Excel, if ‘Send Notes’ is also checked in Setup > Report
and Data Export > [Excel Settings].
These custom notes will be saved with the program and its results, or if changed for a
particular test run, in their amended form with the results.
Custom Notes are not included in Results Data Export other than Excel.
If a Custom Note is enabled but not populated, then where notes are sent to Excel Results
Data, or a report template includes that Custom Note, its title will still appear, but with
its value empty.
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7. Reports and Data Export
Choose how you want to share the results of a test run. Reporting (printed sheets or PDF)
may be all you need, or you may need delimited files of results, or of raw data, or to
transmit directly to another system (e.g. SPC).

7.1 Reports
Reports are straightforward and use templates you have already set up (Setup > System >
[Report Templates]). Choose the detail you want to add: Title, page Header and Footer,
the Results text and/or the graph. With a maximum eight samples per graph, if you want
to overlay more samples they will be split over several graphs.

7.2 Results Data Export
If you are exporting data, decide if you want just the results of calculations per sample, or
the raw data. Raw data means x/y figures for every data point. At 1,000 data points per
second, data files can be very large, so options are added to cut down the amount of data.
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The sequence for setting up a non-default results export (or a new default profile) is:
1. Specify the File Type (CSV, TAB, XML)
2. Specify a file name (browse to destination folder and select or type a new file name, or
allow an automatic filename to be applied).
3. Select Manual or Automatic as the end-of-test action
4. Select the export Scheme ( View show the features from System > Setup > [Schemes])
5. Specify, or leave blank, the batch size (groups of samples)
6. Add samples to export.
When compiling your results export, the samples are listed by number. Select each one
you want and click Add to File . Added samples may be removed. As you add samples,
‘Records in File’ will increment and the export file will be updated.
If a sample is deleted after export, Auto Remove on Sample Deletion will remove it from
the export file automatically.
Batch results handling
When performing a number of tests on samples from a batch, you may want to limit how
many are in one results file. Set your batch size, and when you have added the number of
samples specified as a batch size, you will be alerted to start a new batch:
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Click OK . If you now try to add a new sample:

Click Yes to start a new batch, and, if you are specifying your own file names, begin by
specifying or ensuring a new file name that will not overwrite the first. If you return to add
new samples, click Update to File . The maximum number of samples per batch is 2,000.

7.3 Raw Data Export
Raw data export is similar, but there are no batches or selective sample adding, because it
is assumed that the data are for full analysis elsewhere.
Choose if you want sample data exported in column groups across (arranged
horizontally), rather than sequential samples in one set of time, displacement and load
columns.
Choose if you want to be prompted about modification at the time of export.
Here you will rely on a Raw Data Export Scheme (Setup > System > [Schemes]). However,
because the file size may be very large, you may choose to modify the content by
reducing the amount of data. See Appendix C.2, Managing File Size.
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7.4 Transmission
Direct transmission to a communications port allows you to export Results, or Raw data,
directly to another system. If you need to do this, set the parameters here, using a data
export scheme as profiled in Setup > System > [Schemes]. The View button will show the
structure of your selected Export Scheme.

7.5 Excel settings
If you want to export data to Excel, either set defaults here, or amend the default for the
particular set of results. Note that the format of an Excel cell address is A1, not the
absolute referencing style $A$1.
Things to remember
• A default filename and worksheet will be overwritten if you have set a default and just
use File > Send to Excel after running a test. Either open and resave Excel files to new
files, or use this dialog always before exporting to Excel, and make the export action
‘Manual after test’.
• Excel has limits to number of rows and columns that are easily exceeded by multisample raw data at higher data rates. Use Compress and Cut to reduce the data down
(see Appendix: Managing File Size).
• Incrementing results start cell: unless you are repeatedly running a single sample test
and discarding the Excel data, you will want to ensure each sample begins a new row
in Excel, rather than overwriting the last.
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8. Writing an Emperor Test Program
8.1 Write or edit a test program
A test program is a sequence of commands and information to instruct a test stand
precisely how to manipulate a sample in a way that captures required data. It may
include requests for data entry. A good program is annotated so that both an operator
and a programmer know what is happening and why at each stage.
After a program exercises a test sample or samples, calculations (Section 9, Test
Calculations) are applied that turn the data into evaluated results.
Start a new program with File > New, then Test > Program, or edit an existing program
with File > Load Library Program, then Test > Program. Here, an existing program has been
loaded for editing, with line 18 selected:

8.2 Saving library programs
Always save your library files at each stage of development. When writing complex test
programs, it is good practice to save each stage of development as a new filename (e.g.
MyTest1, MyTest2, etc.). When the final program is all correct, give it a final clear name
and delete the working files.
File locations are set in Setup > System > [File Locations].

8.3 Use of variables
Emperor allows 100 variables (V0 to V99) that can be used in writing programs.
Calculations can also be saved as variables. Their values can be SET (given within a
program line), ASSIGNed (given a current load, displacement or time value), or
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ENTERed (by an operator in response to a dialog box). In the case of displacement(angle),
load, time and speed, units of dimension are added. Number and string (where an
option) are, of course, dimensionless.
Wherever a value is inserted into a command, a variable name (V0 … V99) may be used
instead.

8.4 Commands
Each command has an argument, for which a dialog is provided, with three options:
Append will add the command to the end of the program
Insert will add the command to the line above that currently selected
Update will change the arguments of the selected command

Commands operate in relation to Setup > Preferences (see Section 6). Check these first,
since settings such as what happens at the end of a test, and whether the crosshead Home
position is relative or absolute, will matter before reaching a results display. Other
preferences may be altered afterwards.
Load and displacement preferences relative to absolute zero. Absolute zero position
is a value held within the test stand firmware, and may be altered between program
runs or runs with quite different fixtures. Any program running with reference to
absolute zero position may result in damage to the stand, loadcell, or fixtures.
Be especially careful with signs for load, speed and position (see Appendix: Direction of
Speed, Force and Displacement). Check ‘Debug Program’ so that you can step through and
observe a test program first, to ensure it is performing as expected:
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Command

Argument and use

ASSIGN

places the current value of displacement, load or time into a
variable, V0 to V99

CLEAR DATA

clears all current data from memory. This is useful if part of a
test involves conditioning the sample before testing and taking
measurements.

CLEAR MESSAGE

closes the message box

CLEAR VARIABLES

clears the current values of all variables. Use this at the start or
end of a test to clear all values from memory, otherwise they
can remain from the previous run.

CYCLE

repeats an action a given number of times. Here a compression
test to a displacement of 10 mm (returning to tared zero) is
being repeated six times (cycle 0 = the first; 1 = the first repeat;
etc.).

Example: conditioning a sample may be between two loads,
repeated 50 times, followed by CLEAR DATA before testing.
DIGITAL I/O

When using external devices to digital inputs and outputs, a
program may be made to wait for any or all signals, in or out.
For I/O connections, see Appendix Appendix G: Pin-out
Connections for Digital Inputs and Outputs and Digital Input
Commands and Output Notifications.
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END

stops the program running. This should be placed at the very
end of any program, but also is used to terminate a test early if
a condition (see IF command below) is met.

ENTER

Like ASSIGN, this places a value in a variable (Assign to), but
displays an input box for user input, with the instruction
(Title). The optional initial value is the default value to display,
which the operator may accept or change.
The Parameter for ENTER allows not just load, displacement
and time, but a dimensionless number, speed, and string (110
characters).
Example: use SET for an default batch number, or repeated
prefix (string parameter) and assign to V0. Then, for each
sample, use ENTER with V0 as the initial value, to place the
batch number (confirmed or edited by the operator) in V1 for
the actual batch number.

FORMULA

allows an equation to be written using the operators: + – / * ( )
Example: V15=(V5+V6+V7)/3

HOLD
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A position or load can be held for a given period. This may
allow for relaxation in the sample, or to condition for a
recovery test, or simply to test performance under load. In
order to maintain a load or position, the system will cycle. To
make this effective, the hardness of the material under test, and
therefore the speed of response by the crosshead or platen,
needs to be taken into account.
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HOLD will need to be terminated if the sample breaks or
deforms suddenly, and can be stopped by an Event, such as a
foot switch connected to the digital I/O.

Approach Speed: crosshead speed to achieve the hold point
X-axis: which to hold—load or displacement(angle)
Limit: the load or displacement at which to hold
Break %: when the applied load falls to this percentage of the
maximum load achieved during the operation of this
command, either before or during HOLD, the current
command will terminate and the program will progress to the
next line after the HOLD command. (Example: a break
percentage of 10% is a drop of 10%.)
Note: to avoid misinterpretation of system noise, break
detection is not enabled within a threshold zone of 2% of the
loadcell capacity (e.g. the first 20 N for a 1 kN ILC)
Event detect: ‘On open’ is a change in signal state from 0–1,
‘On close’ is a change in signal state from 1–0
Hold time: duration of an uninterrupted hold.
Sample material: this is a matter of judgement and experience.
The number (1-120) is mm/min speed of crosshead response.
IF

Select the parameter (load, displacement, time, or any variable
V0 to V99) the logical condition (<, <=, <>, = >, >=) and the test
value for comparison.
If the result is True, set the program line number to go to; if the
result is False (≡ELSE), set the program line number to go to.
(These line numbers will automatically be corrected if program
lines are edited in or out.)
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A test sequence can be made recursive (loop) using IF, until
conditions are met and the False outcome moves to another
sequence, or sample release and END, perhaps including a
MESSAGE to the operator.
MESSAGE

Add the text of a message to appear in a yellow box to inform
the operator. This can (for example) accompany events such as
PAUSE or HOLD events (‘Please wait …’), or instructions to
load or remove a sample etc.

PAUSE

delays execution of the next program line by a given amount of
time. Data will continue to be acquired (e.g. for a relaxation
test) unless suspended (e.g. when time is given for an operator
action to be taken).

Note: during a pause, the load value may change (for example
a sample may undergo relaxation or recovery). This will be
seen in sharp, if small, peaks or troughs in the data and graphs.
For pauses greater than 10 seconds, Enable Audio On Pause
will generate a sound towards the end of a pause, which
accelerates towards the end. A visual equivalent could be a
PAUSE followed by a MESSAGE (e.g. ‘resuming in 5 seconds’)
announcing a second 5-second pause.
READ DEVICE

Only active when Integrator module installed. This
command, when added to the Emperor program test sequence,
will take a reading from an external device connected to the
Integrator application and store it in a variable as either a
number or a string (ASCII).
For Integrator and external devices, see manual 431-451,
Integrator User Guide.
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The READ DEVICE command can be used many times
throughout the program to take either several readings from
the same devices at different stages of the test or from different
devices. Remember to use a different variable for each reading
if each reading is to be used in the results display or
calculations section of the test program.
Assign Variable: Select the variable to assign the reading from
the device (V0 – V99).
Parameter: Select what type of parameter the reading from the
device will be stored as, in the variable (Number or String).
Device Name: Enter the name of the device from which the
reading is to be taken. This must be exactly the same name as
set up for the device name in the Integrator application.
Default Value: Enter the value to be stored in the variable as a
non-response indicator, if the device has failed to return a
reading to the Emperor software.
REM

allows a REMark to be inserted into a program to explain a step
or process

REPEAT

is a loop command; return to line number, and number of
times:

RESTORE

undoes a ZERO command for load or displacement

RUN

is the command to move the crosshead or platen, and decide
when to stop. Set the Speed, and any of Load, Displacement
(Angle) and Time. Whichever condition is reached first will
end the RUN command. RUN may also be terminated by a
switch event or by break detection.
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Note: if you choose displacement ‘From absolute zero
position’, remember that this setting is held in the stand
firmware and if changed between program runs will alter the
outcome, or cause damage to the system.

Break %: when the applied load falls to this percentage of the
maximum load achieved during the operation of this
command, the RUN command will terminate and the program
will progress to the next line. (Example: a break percentage of
10% is a drop of 10%.)
Note: to avoid misinterpretation of system noise, break
detection is not enabled within a threshold zone of 2% of the
loadcell capacity (e.g. the first 20 N for a 1 kN ILC)
Event detect: ‘On open’ is a change in signal state from 0–1,
‘On close’ is a change in signal state from 1–0
SET

gives a value and dimensions to a variable (V0 to V99). It can
therefore set an initial value, to be reused in other commands,
or reset a value.

ZERO

sets either load or displacement to zero (tare). RESTORE will
undo ZERO if used once. When used twice in succession,
RESTORE will not undo ZERO; the displacement or load
values are lost.
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9. Test Calculations
9.1 About multi-valued functions
Consider the general equation:
y = f(x)
In a simple situation, when given the value of ‘x’ and asked to calculate ‘y’ there may be
only one result—in this case the function is called ‘monotonic’. For example:
y = ax + b
has only one solution, because for any value of ‘x’ there is only one possible value of ‘y’.
Most functions, however, are either inherently multi-valued, or else noise on a signal can
make an inherently single-valued dataset multi-valued. Consider a peel adhesion curve:

Load is on the ‘y’ axis and displacement is on the ‘x’ axis. If you need to know the
displacement {x} at a certain load {y}, there may be more than one solution.
Similarly, consider the case of a cyclic test:

This graph shows load/displacement data obtained by applying two compression cycles
to a block of polyurethane foam. For each value of load, there are four corresponding
displacement values, and for each value of displacement there are four corresponding
load values (illustrated). This is most obvious for the compression stroke (i.e. the top two
curves) where, for a given displacement, the load on the first cycle was significantly
greater than the load on the second, as illustrated by the blue crosses. It is not so obvious
on the return cycle, as illustrated by the lower green crosses. The difference is due to the
plastic deformation of the foam.
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9.2 Selecting calculations
From the top menu, Test > Calculations these calculations are available:

Select a calculation command from the drop-down box, and press Edit to add the
calculation parameters. Here, for example is the Average command:

Append adds the calculation to the end row.
Insert adds the calculation to line above the selected row.
Update overwrites the selected row with the new edit.

When all calculation lines are complete, press OK to save, Cancel to revert to last
save, Clear all to remove all calculation lines, or Print to send direct to the printer
allocated under File > Print Setup …

9.2.1 Command functions
Trend lines

BEST-FIT; SLOPE

Change points

BREAK; KINK; STEP

Max./Min.

PEAK; TROUGH
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Averages

AVERAGE; RMS

Explanation

REM; INFORMATION; PRINT-WHEN; TIME-STAMP; VALUE

Process

AREA; DO-SUM; SET; VARIABLE

9.2.2 Parameters common to many calculations
Result title
This will identify the line in the Results Grid (there may be more than one average in this
overall calculation). It is also about the reason for the calculated line, so a SLOPE
command used to determine a spring rate, is better described as that than the default title
‘SLOPE’.
{X} and {Y}
These are assigned to load, displacement or time (displacement is ‘angle’ in torque
systems). In some cases {X} can also be assigned to an event.
Start and Finish
are initial and final values for X (in the above example, this is the average load Y for
displacement span X). Units are assigned accordingly for force and torque load, and for
displacement/angle. Left blank, the value from the start and/or end of the test will be
used. You may not know the best values for these until you have run some tests, so they
are adjustable once you have some results, from the graphical display:
Drag-enabled points: Start and Finish points may subsequently be dragged in Display
> Interrogate > Time Line to adjust the original settings in the results file calculation. This
file may then be saved with the adjustments. If you use this feature, when you exit
Emperor you will be asked if you want to also save the changes to your program
library file, under the same or a new name.
Note: if you use Variables for the values in Start and Finish points in your program
library file, these will be overwritten with numerical values if interrogated and the
slider points are moved. Be careful not to overwrite your original program file.
Occurrence
Occurrence is a way of detecting change points in VALUE, KINK and STEP. In the case of
VALUE and KINK, the interval between occurrences has a time limit.
Example: in a cyclic test, detect the first, second, fifth and sixth times the recorded load
passes a certain point.
Since in any test there can be a degree of noise, change can be transient. There is therefore
a requirement that between selected occurrences there needs to be an interval of at least
one second so that Emperor ‘knows’ the change is a significant point, not a transient one.
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In the following diagram, the trace is not visibly noisy, but compare the example
requirement quoted above, for loads A, B and C. Imagine load B is the required load
point.

We can clearly see that each time the graph passes the required point, over one second
has passed. Occurrences 1, 2, 5 and 6 are all present and in order.
Next imagine that load A is the required load point. Here actual transits of this value (3, 5
and 7) are missed because they are at less than 1 second after the previous occurrence,
and so are not detected as change points (i.e. occurrences). Occurrences 1 and 2 are as
expected, but 5 and six are not.
Finally, imagine load C is the required load point. Here every second pass of the load
value will be ignored, because the period between occurrences at the peak is always less
than 1 second. Here occurrence 6 is not even present, so the test will fail.
Assign to (Variables)
In most calculation commands, results can be assigned to variables (V0 to V99 are
available), on which further calculations can be performed.
Hide Result
If the result is only a part of an extended calculation, and has no particular importance in
itself, use Hide Result and it will not appear in the Results Grid.
Verify result
Ticking this check box and entering minimum and maximum values, allows the
calculation line to also yield a true/false result, which can be interpreted as a pass/fail
marker. If the calculated result lies between the minimum and maximum, the result will
be printed with a green background in the Results Grid, and in green text in a report.
Results that are below the minimum or greater than the maximum will be printed with a
red background in the Results Grid, and in red text in a report.
Overall result
If at least one calculation is to be Verified, then a final row can be added to the list of
calculations on the Results Grid, called Overall Result. Overall result is ‘Pass’ if all the
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included verified results are met. If any of the included verified results are not met, then
Overall Result is also ‘Fail’. Whether to show the Overall result, and whether to include
hidden results in the overall result for a particular results file, are set up in Setup >
Preferences > [Results Display]. These settings can also be made for Report Templates and
Export Schemes. (See Appendix D: A Note on Overall Result and Hidden Results.)

9.3 Calculations
Command

Argument and use

AREA

The AREA calculation returns the area under the curve for
defined ‘start’ and ‘finish’ values of {X}, for example to
measure total energy exchange over a period of time or for a
given change in displacement.

Note: if the curve drops below a zero value of {Y}, the area
does not become negative. All area is regarded as
accumulative.
AVERAGE

The AVERAGE calculation returns the average value of {Y} for
chosen ‘start’ and ‘finish’ values of {X}. You can derive the
result as the ‘Average’, i.e. the arithmetic mean, or as the
‘RMSE’ value from Average (see next below).

Result is: Choose between Average (Units) and RMSE
(unitless)
RMSE: The root mean square error (RMSE) is a frequently-used
measure of the differences between values predicted by a
model or an estimator and the values actually observed. RMSE
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is a good measure of accuracy. These individual differences are
also called residuals, and the RMSE serves to aggregate them
into a single measure of predictive power.
BEST-FIT

(Linear Regression)
Result is: From the BEST-FIT command you can obtain a result
for the straight line of best fit through all the data points within
an x-range, that will give the gradient, the y-intercept, or the
RMSE (see above).
The SLOPE command is similar, but SLOPE is the gradient of a
line passing through the start and finish data points.

BREAK

This returns the value (of load, displacement or time) when a
sample break has been detected. The break can be defined as
either a ‘sharp’ break, or as a ‘percentage’ break. A sharp break
is typically chosen when the sample suffers a sudden fracture
or the break occurs near-instantaneously. A percentage break is
more suitable when the sample stretches slowly, and the break
occurs progressively over time (explained more fully below).
Calculations after a break are made by comparing consecutive
data points, according to the criteria given below. This may not
necessarily be at the same point as where the break detector
has operated.
Result is: Choose ‘Load’ or ‘Displacement/Angle’ or ‘Time’.
Type: Choose ‘Sharp’ or ‘Percentage’. ‘Threshold’ is the % of
loadcell capacity below which break will not be detected, in
order to avoid misinterpretation of system noise.
Sharp:
Change factor—default value is 5 (range 2 to 20)
Threshold %—default value is 3 (range 1 to 90)
Percentage:
% Drop—default value is 40 (range 1 to 99)
Elongation—default value is 1.25 (range 0.01 to 1,000)
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Sharp break

Sharp break is detected when analysing a set of three data
points a, b, c, and the following criteria are met:
b > {change factor} × a
c < {break %} × Fmax
Where
a = the change in load between the first set of data points
b = the change in load between the second set of data points
c = the load value above zero of the last data point
Fmax = maximum load
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Percentage break

Percentage break is detected when analysing a set of data
points and the following criteria are met:
El2 ≥ El1 + ∆El
L2 ≤ L1 × (1 – %drop/100)
Where
L1 = first load point
L2 = second load point
El1 = Elongation at L1
El2 = Elongation at L2
∆El = required change in elongation = {elongation}
%drop = percentage drop in load required between L1 and L2. =
{%drop}
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DO-SUM

DO-SUM allows for calculations using Variables. Add units for
your own clarity, and for dimensionless results, insert a space.

Expression: Valid operators are: + - / * ( ), and the string must
be free from dimensional conflict (see VARIABLE).
INFORMATION

This will add additional information to the sample results.
Information: Use the drop-down box to select:
Bad sample reason: This will give the reason why a test run
was not completed satisfactorily, e.g. ‘Emergency Stop button
pressed’.
Operator’s name: This is taken from the User name logged on
when the sample was run. It links the sample result to the
operator.
SDC Status: Whether a system deflection calculation was
included in the results.

KINK

Kink is based on Slope. If an abrupt change in Slope is
detected, such as when a test sample disintegrates suddenly, a
KINK point where the two Slope lines intersect is recorded.

The diagram shows data points at the selected time interval in
the KINK command between start and finish.
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A SLOPE calculation is made at each of these intervals and
compared with the last.
If the angle between consecutive slopes exceeds the minimum
angle selected, the KINK point is determined to be the data
point at the end of the previous interval.

Interval: A time period over which the direction may be seen
to change (default 0.3 s, minimum 0.01 s). A comparison is
constantly made between the slope of the previous and
following set of data points in the chosen interval.
Occurrence: There may be more than one abrupt change (for
example after a take-up tension, a slippage release). See note in
Section 9.1 on occurrence intervals.
Minimum angle: The change in angle that determines that a
KINK has been detected rather than noise or regular variability
(default 10°).
Result: Define location of KINK as the time, displacement or
load, at the point of detected slope change.
PEAK

Returns the maximum {Y} value of the chosen parameter,
‘Load’, ‘Displacement’ or ‘Time’, for a defined range of {X}
values. You can choose to report the highest of all the {Y}
values, or select a peak of interest by setting ‘Start’ and ‘Finish’
values, and by inserting values in the ‘Order’ and ‘%’ boxes.
Order: Order 0 = max. value within the range of {X}, which
may or may not be a peak with downturn.
Order 1 = highest peak value within the range of {X}, defined
as a peak with downturn, by the % value.
Order 2 = second highest peak value within the range of {X},
defined as a peak with downturn, by the % value, and so on.
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%: The per cent field allows the PEAK calculation to
distinguish between small spikes that are a genuine signal, and
background noise. If after the peak the {Y} value does not fall
by at least the selected percentage of the total range of {Y}
values, then that spike is not a genuine peak. If, however, there
are two peaks that are very close together, it may be necessary
to experiment with different values in the ‘%:’ box.
PRINT-WHEN

The PRINT WHEN calculation applies a test to the value of the
result from a line number in the Selected Calculations list and
returns text that depends on the result of a conditional test.
Note: the PRINT-WHEN calculation must be used after the
calculation to be tested.
Result title: This is a free-form text entry field that allows you
to re-name the test result. This title will appear as the row
header in the results grid.
Calculation no.: This is the line number of the calculation to be
tested as they appear in the ‘Selected Calculations’ list on the
[Calculations] tab.
Condition: Choose the Boolean test to be applied from the
drop-down list:
<, <=, <>, =, >, >=
Test value: Enter the test value
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True text: Enter the text to be displayed if the test condition is
met.
False text: Enter the text to be displayed if the test condition is
not met.
REM

REM is the facility to add a comment (remark) line in the
program, typically to explain a subsequent program step.

RMS

(Root Mean Squared) Where an average is required over values
where negative displacement/angle are involved (e.g. in a
bidirectional cyclic test), AVERAGE cannot be used. RMS must
be used instead.
The RMS calculation returns the RMS value of {Y} for chosen
‘start’ and ‘finish’ values of {X}. You can derive the result as the
RMS average, or as the RMSE value from RMS.

SET

The SET command is used to give values to Variables.

Here Variable V9, in a torque program calculation, is being
given the value for an angle of 45 degrees. (Choosing the
parameter will then bring up the range of appropriate units for
selection.)
SLOPE

Result is: From the SLOPE command you can obtain a result
for the straight line joining the first and last data points within
an x-range, that will give the gradient, the y-intercept, or the
RMSE (see under 0 above).
The BEST-FIT command is similar, but BEST-FIT is the gradient
of a line passing equally through all the data points.
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STEP

STEP returns the value of {X} when the value of {Y} changes
sharply from one steady value to another.

‘From’ and ‘To’: The lower and upper limits of the range of {Y}
to be assessed. {X} is the displacement, load or time to return
for the step change.
%: The step line will not be perfectly vertical, so the ‘moment’
of the step change can be set at the first {Y} point in the range
(0%), the last {Y} point (100%) or somewhere between (50% is
halfway).
Occurrence: There may be several step changes or slippage
points, in either direction. Occurrence allows you to specify the
one of interest.
TIME-STAMP

Used to add the date and time the test started and/or finished.
Use the Radio button to select the time: Start time is taken when
the blue ‘Start’ button is pressed. The End time is recorded
when the test has finished, or if terminated by pressing the red
‘Stop’ button. You can display both start and end times by
adding two Time-Stamp calculations. TIME-STAMP is
displayed in HH:MM:SS format.

TROUGH

The TROUGH calculation returns the minimum value of {Y} of
the chosen parameter of ‘Load’ or ‘Displacement’ or ‘Time’
within a defined ‘Start’ and ‘Finish’ value of {X}. You can
choose to report the lowest of all the {Y} values (deepest
trough), or select the area or trough of interest by setting the
‘Start’ and ‘Finish’ values, and by inserting values in the
‘Order’ and ‘%’ boxes.
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Order: Order 0 = min. value within the range of {X}, which may
or may not be a trough with upturn.
Order 1 = lowest trough value within the range of {X}, defined
as a trough with upturn, by the % value.
Order 2 = second lowest trough value within the range of {X},
defined as a trough with upturn, by the % value, and so on.
%: The per cent field allows the TROUGH command to
distinguish between small dips, which are a genuine signal,
and background noise. If after the trough the {Y} value does not
climb by at least the selected percentage of the total range of
{Y} values, then that dip is not a genuine trough. If, however,
there are two troughs that are very close together, it may be
necessary to experiment with different values in the ‘%:’ box.
VALUE

70  Mecmesin

The VALUE calculation returns the value of {Y} for a specified
value of {X}. {Y} can be ‘Load’, Displacement/Angle’ or ‘Time’.
{X} can be ‘Load’, Displacement/Angle’, ‘Time’ or an ‘Event’.
See the discussion at the beginning of this section, on Multivalued functions.
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Value: Enter the desired value of {X} at which point the Value
of {Y} will be recorded. If ‘Event’ has been chosen for the {X}
parameter, then the options for value are on ‘open’ or on
‘close’. In this case, when an I/O event signal changes from 0 to
1 (open) or from 1 to 0 (close), the Value will be recorded.
Drag-enabled: Value may be dragged in Graphical display
Occurrence: Enter a number to return the value of {Y}
corresponding to the occurrence of the {Y} value of interest.
E.g. if you want to find the load {Y}, at its third occurrence, at a
displacement of {X}, then enter 3 in the occurrence entry box.
See note in Section 9.1 on occurrence intervals.
VARIABLE

Variables V0 to V99 are available to be described (limit of 50
characters) and to which values or calculation results can be
assigned (limit of 40 characters).

Dimensional conflict:
Care must be taken in compiling calculations and assigning
them to variables for further calculation. Emperor will alert
you to errors that lead to a conflict in dimensions, such as an
instruction for speed in units of force. To derive numerical
quantities from dimensioned values they must be divided by
values of equal dimension. 125 N divided by 5 is 25 N, whereas
125 N divided by 25 N is simply 5, by normal mathematical
convention.
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10. Running Emperor Programs and Saving Results
10.1 Preparing
Check your stand, fixtures and sample are secure, and that if you use absolute zero
position in your programs, that this is set correctly. Check the appropriate loadcell is in
place for the test to be run.
Absolute zero
If position relative to absolute zero is used in any programs, it is important to have a
standard procedure, which could involve making a strict rule:
1. Absolute zero is an unchanging position and can be set by procedure routinely.
or:
2. Absolute zero is always a touch-together position between fixtures that is taken into
account by every program that references an absolute position.
or:
3. Absolute zero is never used as a relative point in any programs.

10.2 Running
Load the required program. If another test has been previously run, make sure that if
results are still present on the system, these have been saved or exported. If appropriate,
run the crosshead and fixtures manually to a safe initial position, or for securing your
first sample.
Position the first sample within the fixtures, click START and follow the test run through
with each sample in turn. At any point you can choose to:
• display multiple traces for comparison (Display > Overlays)
• view the current or all samples in results (Setup > Preferences > [Results Display])
• include or remove individual samples from the overall statistics
• interrogate individual samples (Display > Interrogate)
• delete individual samples (Specimen toolbar: requires permission at operator level)

10.3 Including and discarding samples
The inclusion of samples in the statistics is stored with the file. It does not remove any
data. Discarding samples is done by using the ‘Delete’ basket on the Specimen toolbar.
This deletion is irretrievable.
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10.4 Saving results
The first time you save results (unless you have Setup > Preferences > [General] set to
‘Autosave’), you must use File > Save As. Thereafter, File > Save (or Ctrl+S) will overwrite
the same file. You can at any time save your results file, run further samples and save
again.
To split results into more than one file, save the results, then reload the library file. This
will close the previous results file.
To add samples to an existing results file, File > Open the results file, insert a new sample,
run the test, and save. If you do not wish to save with new samples (and are not using
autosave), either delete the new sample(s) or use File > New to close the previous results.

10.5 Exporting results
Unless you have automatic export at the end of each test, you can choose to export raw
data to file (defined in Setup > Report and Data Export > [Raw Data Export]), and use File >
Export.
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Relative and Absolute Positions:
Zero, Home and Start

A.1 Absolute Zero position
You can set an Absolute Zero position of a force-system crosshead or torque-system drive
spindle. This can be used as a reference point in any program, and any program that has
reference to an Absolute Zero requires this to be set in order to run. This setting is held in
the firmware of the test stand, so remains even when the system is switched off.

How to set the Absolute Zero position of the crosshead or platen
Move the crosshead or platen to the required reference position.
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• In the Programmed Testing screen, click the

button.

• Set Absolute zero, either as zero (0) for the current position, or as an offset away from
the current position (shown in the example below as 15 mm above the current
position), then press Set and Exit . Note: here is where you can also Clear Absolute
zero, reposition the crosshead or platen, and reassert a new Absolute zero.

Caution! If you position the crosshead, with or without fixtures, in contact with the
anvil plate (MultiTest) you must not use a positive offset: this is always in a downwards
direction irrespective of test direction!

A.2 Tare positions
Tare positions mean ‘treat this as the reference point for the next measurement’. Tare
position setting does not alter an Absolute Zero setting. A tare positions can be:
• a temporary tare position (e.g. set Zero Displacement
overwritten by tare positioning within a program.

in the toolbar). This is

• a point in any program where the ZERO command is used for position.

A.3 Home
Home is defined in Setup > Preferences > [General], and for each program, as being
either relative to Absolute zero, or relative to the latest tared zero. An instruction to
‘Return to Home’ may, for example, be used to provide clearance for the exchange of
samples or grips.

A.4 Taring load
When measuring the difference between loads, as when pre-tensioning a spring, or
measuring consistency in mid-travel compression, or simply to eliminate the touch-on
detection load, you will need to also tare a load in the same way as position.
Caution: When manually taring the load while a large force is being applied to the
sample, the display will show the force to be zero, but the sample will still be under
tension or compression. Use the Jog buttons to release the load before attempting to
remove the sample.
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Direction of Speed, Force and Displacement
Displacement, rotation, load and speed all increase in a test’s direction of travel as
defined in Setup > Preferences > [General] (i.e. compression/tension, clockwise/
anticlockwise). Negative values are always away from the direction of travel. Sign of
speed must follow sign of displacement:
example: RUN @ –100 mm/min until position from tared zero = –20.00 mm
The following tables show how speed, displacement and force appeared in compression
and tension tests.

Force
Compression test
Crosshead direction
Position, load and speed are:

increasing

decreasing

Tension test
Crosshead direction
Position, load and speed are:

increasing

decreasing

Torque
In an anticlockwise test (e.g. to release a screw cap), the spindle will move clockwise so that
the sample moves anticlockwise with respect to the torque cell.
Clockwise test

Anti-clockwise test

The spindle moves anticlockwise and:

The spindle moves clockwise and:

spindle angle increases (goes to a positive
angular displacement from zero)

spindle angle decreases (goes to a negative angular
displacement from zero)

Instruction to run to a positive angle will rotate
the spindle anticlockwise at a positive speed.

Instruction to run to a positive angle will rotate the
spindle clockwise at a positive speed.

Instruction to run to a negative angle will rotate
the spindle clockwise at a negative speed.

Instruction to run to a negative angle will rotate the
spindle anticlockwise at a negative speed.
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Handling Data Files
C.1 Where Results Go
Familiarise yourself with the movement of data and its destination, so that you can
establish a way of working that organises your files well.
Action with results

Destination of data

RUN a test

Sample results accumulate in memory.

Save results of run 1

A default filename is presented comprising the test name and a current
date-time stamp. You may choose an alternative file name.
The file is saved to the Emperor\Force[Torque]\Results folder.

Export results of run 1

Sample data are sent to file as specified for the test (Setup > Report
and Data Export). You may not choose a new file name, and an existing
file of this name will be overwritten.
The file is saved to the Emperor\Force[Torque]\Export folder.

RUN a test again

Sample results accumulate in Console memory.

Save results of run 2

A default filename is presented comprising the test name and a current
date-time stamp. You may choose an alternative file name.
The file is saved to the Emperor\Force[Torque]\Results folder.

Export results of run 2

Sample data are sent to file as specified for the test (Setup > Report
and Data Export). You may not choose a new file name, and an existing
file of this name will be overwritten.
The file is saved to the Emperor\Force[Torque]\Export folder.

OPEN results file

Select a file from the Results library and Edit or Run.

RUN the test again

The test program is loaded with the previous results, and further
samples tested will be added to the previous results.

Save results after run 3

The previous filename as opened is presented. Save to this file to
overwrite the previous version, or choose a different filename. A new
date-time stamp is not offered.
The file is saved to the Emperor\Force[Torque]\Results folder.

Export results after run 3

Sample data are sent to file as specified for the test (Setup > Report
and Data Export). You may not choose a new file name, and an existing
file of this name will be overwritten.
The file is saved to the Emperor\Force[Torque]\Export folder.
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C.2 Managing File Size
File size is directly proportional to the total number of data points acquired. The higher
the data acquisition rate (Setup > Preferences > [Data Acquisition]) and the longer the test
duration, the larger the Results file becomes.
Data acquisition should be selected for the degree of detail required and precision of
interpretation. For exporting results, however, or after seeing test results, less detail may
be required and a smaller file can be obtained by compressing, cutting or cropping the
data.

Data acquisition rate
Determines the total number of data points per sample test (sample tests may have
different durations). This and the number of samples per results file, dictates the saved
file size.

Compress
To reduce file size, if some detail can be sacrificed, every third or fourth data point (for
example) can be saved. In the data modification dialogs, 3 means only include 1 in 3 data
points, 4 means 1 in 4 (a quarter of the file size) and so on.

Cut
Enter the number of data points (span) to which you want to limit the raw results. This
may eliminate a long tail but be careful not to lose essential features or individual
samples with more data points than the rest.

Crop
Define a time span that limits the data to an area of interest (e.g. the last 30 seconds).
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A Note on Overall Result and Hidden Results
A verified calculation is one where upper and lower criteria are set, and the result is a
Pass (within limits) or Fail (outside limits).
An Overall Result is a Pass or Fail status based on all included verified calculations.
A Hidden Result is one that you choose not to show in the results. Perhaps its value is not
of importance in itself, but where also verified, it can still influence the Overall Result if
you choose, in which case you must Include Hidden Results in calculating the Overall
Result. If you hide some verified results but not others, this could potentially be
confusing. Here is an example of five calculation steps and an Overall Result.
 = ‘yes’,  = ‘no’,  = contributes to overall result
Calculation step

verified

hidden

where the
result is:

1





Fail



2





—



3





—



4





Pass







5





Pass







Pass

Fail

Overall Result

Result
visible

 do not include
hidden results

 include
hidden results


This feature is mainly useful for hiding all the verified criteria whilst leaving the Overall
Result visible. There are three locations where this matters:
Set-up > Preferences > [Results display]
Set-up > System > [Schemes] (for data export)
Set-up > System > [Report Templates] (for printing results as reports)
In each, you decide whether to show an overall result, and in each, any hidden results
will not be shown.
Note: inclusion of samples in a results file or display is quite separate; individual samples
can be included or not in the statistics of a batch, in export and in reporting. This is not
the same as hiding calculation results.
Now examine the following Results Grids carefully. We hide verified result 2 and then
don’t include it. This affects the overall result, but in the second grid we can’t see why the
sample has failed.
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Example Results Grid: if any verified result fails, the overall result is fail:
Results

Sample 3

Sample 2

Sample 1

Included







unverified result

### Units

### Units

### Units

PASS

FAIL

FAIL

verified result 1
verified result 2
verified result 3
Overall result

The second verified result is now hidden; hidden results have been included, sample 2 fails:
Results

Sample 3

Sample 2

Sample 1

Included







unverified result

### Units

### Units

### Units

PASS

FAIL

FAIL

verified result 1
verified result 3
Overall result

The second verified result is hidden; hidden results are now not included, sample 2 passes:
Results

Sample 3

Sample 2

Sample 1

Included







unverified result

### Units

### Units

### Units

PASS

PASS

FAIL

verified result 1
verified result 3
Overall result

You may choose to hide all verified results, but still include them:
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Results

Sample 3

Sample 2

Sample 1

Included







unverified result

### Units

### Units

### Units

Overall result

PASS

FAIL

FAIL

Emperor Force and Torque Operator Manual

Note:
• In the Results Grid view, Overall result for bad samples are always set to fail, but
automatically not included.
• For digital output (e.g. set output on FAIL) the digital output is synchronised to the
Overall Result as displayed in the Results Grid view.
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Tolerance Bands
Test data can be visually compared with a reference specimen by using the Tolerance
Band overlay option (Display > Overlays). This requires a tab- or comma-delimited text file
containing the reference data. There must be two columns representing the y-axis and xaxis respectively, with units in row 2 and data beginning in row 3, as in this example:
y-axis,x-axis
mm,N
0.30,1.00
0.50,1.40
0.70,1.85
etc.

The data may be derived from theoretical results, or from a reference test, and must be in
the same units as the results to be compared. There should be no more than 100 data
points.
With a Results file open, browse to the reference file in Display > Overlays:

Two types of tolerance bands can be generated. Typing a number into the Factor box
(20%, for example) will generate a factor-based tolerance band:
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The data in the reference file are shown in red, and the tolerance limits that will appear
on the graph are shown in green.
Typing a number into the Difference box (5 N/N.m, for example) will generate a
difference-based tolerance band:

Note: tolerance bands are calculated on the basis of there being an acceptable range of
values for the parameter plotted on the y-axis. If, for example, data have been plotted as
Load/Displacement(Angle), but you need to work with a specification that requires test
data to be within ± 5 mm(degrees) of the data for a reference specimen, then use the
‘Others’ option in Display > Settings to generate a Displacement(Angle)/Load plot.
It can be awkward to devise the calculation(s) necessary to detect when a sample is not
within tolerance, but Emperor can do this automatically. Check the ‘Display Tolerance
Alert’ box, to display a warning in the Results screen when tolerances are exceeded.
Data that ‘fail’ (i.e. fall outside the y-axis limits of the tolerance band) are plotted in red,
but data that ‘pass’ (i.e. fall within the y-axis limits of the tolerance band) are plotted in
green. Data that fall outside the x-axis limits of the tolerance band) are plotted in black.
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Digital Input Commands and Output Notifications
Mecmesin test stands have the facility for six digital inputs and six digital outputs that
can be used to integrate the test stand with programmable logic controllers (PLCs) or
other equipment.
Setting up the inputs and outputs is done in the [Test Settings] tab of the Program Test
Set-up screen. To allocate a function to the input or output, first select a Digital Input or
Digital Output. Then choose a function from the drop-down box to the right of the
selected input or output. The alternative functions are:

F.1 Available commands for digital inputs
OFF
START TEST (Idle mode event)
STOP TEST (Testing mode event)
START ACQUISITION Testing mode event)
STOP ACQUISITION (Testing mode event)
TARE LOAD (Idle mode event)
TARE POSITION (Idle mode event)
TARE BOTH (Idle mode event)
GO HOME (Idle mode event)

F.2 Available notifications for digital outputs
OFF
TEST STARTED (Testing mode event)
TEST STOPPED - COMPLETED OK (Testing mode event)
TEST STOPPED – EMERGENCY STOP (Testing mode event)
TEST STOPPED – USER (Testing mode event)
TEST STOPPED – ALL (Testing mode event)
AT HOME POSITION (Testing mode event)
TEST RESULTS – PASS (Idle mode event)
TESTRESULTS – FAIL (Idle mode event)
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Pin-out Connections for Digital Inputs and Outputs
G.1 Digital inputs
• Input voltage range is 0 to +5V
• The input pins are normally high (+5V) and should be pulled low (0V) for a minimum
of 100 ms to trigger an operation

G.2 Digital outputs
• Normally low (0V)
• When set the appropriate output pin is pulsed high (+5V) for 500ms

Digital Output circuit
25-Way D-type pin

Function

25-Way D-type pin

Function

1

Not connected

14

Digital output 1

2

Auxiliary receive

15

Digital output 2

3

Auxiliary transmit

16

Digital output 3

4

Not connected

17

Digital output 4

5

Not connected

18

Digital output 5

6

Not connected

19

Digital output 6

7

Ground

20

Not connected

8

Not connected

21

VCC (+5V)

9

Digital input 1

22

Not connected

10

Digital input 2

23

Event input

11

Digital input 3

24

Digital input 6

12

Digital input 4

25

Ground

13

Digital input 5
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RS232 protocol
H.1 Comm port settings:
Data bits: 8

Parity: None
Stop bits: 1
Flow control: None
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Bad Sample Messages and Error Codes
If a test does not complete, it will be marked as ‘Bad’ in the sample status in the sample
management section on the Info/Help screen. Bad results are not included in ‘Mean’ and
‘SD’ calculations in the Results grid, but can be printed in a report. You can get more
information on the cause of the problem by adding an ‘Information’ calculation in a
program test. This will then show the Reason code in the ‘Bad sample reason’ line
displayed in the Results grid.

I.1

Error messages

Error message

Cause

‘Stopped by operator’

The run has been stopped by pressing the red ‘Stop’ button
on the Live Test Run screen

‘Aborted by test system [0x0000000N]’

The system has stopped the run. By adding an ‘Information’
calculation line to a Program Test, a Reason code will be
displayed in the Results grid. See below for a list of the
Reason codes.

‘Stopped by external input’

Test stopped due to a digital input

‘No data acquired’

No data has been acquired

‘Program not completed’

Program not finished, typically this will happen when a
communication error occurs and aborts program execution

I.2

Reason codes

These codes indicate the reason for the test not finishing successfully. The codes
displayed can be for a single reason, or if more than one failure has occurred the codes
will be added together. For example, in the case of a single fault, the code [0x00000001]
means ‘Motor current limit Encountered’.
In the case of a multiple fault, a code of [0x00000003] would be displayed if both
[0x00000001] ‘Motor current limit Encountered’ and [0x00000002] ‘Motor drive has been
disabled’ had occurred at the same time.
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Fault code

Reason

0x00000001

Motor Current Limit Encountered

0x00000002

Motor Drive Has Been disabled

0x00000004

Test stand has recovered from reaching the upper limit of travel

0x00000008

Test stand has recovered from reaching the lower limit of travel

0x00000020

Emergency Stop Button Pressed

0x00000040

Overtravel Switch Encountered

0x00000080

Overload detected, automatic recovery

0x00000100

Intelligent Load Cell not present, Switch test stand off and check the link. Allowing
limited access.

0x00000200

Test Stand Data Buffer Overflow

0x00000800

Tachometer Failure

0x00001000

PID Overflow Too Many Times

0x00002000

PC Comms watchdog has timed out. Allowing limited access.

0x00004000

Failed holding the motor

0x00008000

Motor deceleration failure

0x00010000

Intelligent Load Cell receive load error

0x00020000

Test Stand transmit buffer is full

0x00040000

Invalid parameter in Test Stand PIC

0x00080000

Real Time Controller PIC failure, Switch test stand off, contact your Agent/Distributor.
Allowing limited access to stand

0x00100000

Overload detected.

0x00200000

Test Stand has not been calibrated. Allowing limited access.

0x00400000

Extensometer jump detected

0x00800000

Invalid parameter sent to Test Stand
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Setting up an -i Series Test Stand to Run as
an -xt System
Test stands are normally configured to run either from a touch-screen console
(-xt systems) or PC (-i systems), but can be run from either, via this update.
If you have an –i series test stand and wish to connect your PC as a console, or add a
console to the stand, you will have been supplied with a memory stick containing a folder
named Advanced Program Builder Option and which contains a single file to upgrade
the test stand.
Note: the Advanced Builder Option files are supplied for a specified stand serial
number, and can only be installed on that stand.
Check that the file name is identical to the serial number of your stand, (an example of
the format is 12-1046-07). The serial number can be found on the rear of the stand (or on
the right-hand side of twin-column MultiTest stands). Contact your authorised Mecmesin
distributor if the serial number in the file name is different.
Copy this numbered file, open your desktop shortcut to the Emperor (Force / Torque)
Data folder, open the subfolder named \Upgrade and paste the file in.
Now open Emperor, log in as a Master user and go to the top menu to select: Tools >
Service > Update Options:

Click Get File and your update file will be visible. Select it and click Open . Your stand
serial number now shows above the Update Options button, which is now live; click it:

Your stand is updated.
You can see whether an -i stand connected to Emperor is updated for –xt operation by
checking Tools > Service > Stand Configuration where Stand Options should read 3.
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Index
A

absolute position
display, 33
absolute zero, 77, 79, 80
set, clear, 80
accumulative angle, 40
accumulative displacement, 40
automate (end of test), 41
automatic log on, 7
autosave, 38

B

bad samples, 87, 94
batch results handling, 48

C

calculations, 61, 62
Area, 65
Average, 65
Best-fit, 66
Break, 66
dimensional conflict, 75
Do-sum, 69
Information, 69
Peak, 70
Print when, 71
Rem, 72
RMS, 72
RMSE, 66
SET variables, 72
Slope, 72
Step, 73
Time-stamp, 73
Trough, 74
Value, 74
Variables, 75
change a user, 7
comm port settings, 93
commands, 53
compress, 84
connecting to the test stand, 8
console mode, 6
create a new user, 7
crop, 84
cursor drop, 30
cursor snap, 41
custom notes, 44
cut, 84

D

data acquisition
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optimise, 43
data acquisition rate, 84
data capture window, 43
data export order, 14
data folders, 2
data schemes, 13
data transmission, 50
default settings, 35
diagnostic report, 26
digital inputs and outputs, 43, 90
pin-out connections, 54, 91
direction (speed, force, displacement), 82
direction, setting, 37
display menu, 22

E

error messages, 94
Excel settings, 50

F

favourite programs, 8
file locations, 12
file menu, 19
file size management, 84
filename format, 39

G

graph
auto-ranging, 40
auto-scaling, 40
graph analysis mode, 30
graph settings, 30, 39
graph toolbar, 30
gridlines and scale, 40
group, 9

H

handling data files, 83
hardness, 56
help, 27
hidden results, 85
include, 42
hide result, 64
home, 33, 80
home position, 38

I

Integrator, 58

J

jog controls, 29
jog speed, 38
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L

legends (graph), 40
limited functionality, 26
limits, 38
loadcell capacity, 4
logging on, 4

M

markers, 41
minimum specification, 2

O

Occurrence, 63
offset, 22
overall result, 65, 85
display, 42
overlays, 22

P

percentage break, 68
power failure, 4
preferences, 35
program commands
Assign, 54
Clear data, 54
Clear message, 54
Clear variables, 54
Cycle, 54
Digital I/O, 54
End, 55
Enter, 55
Formula, 55
Hold, 56
Kink, 69
Message, 57
Pause, 57
Read Device, 58
REM, 58
Repeat, 59
Restore, 59
Run, 59
Set, 59
Zero, 60
program settings, 35
programmed testing, 19

R

raw data export, 49
reason codes, 94
recalculate, 27
reconnect, 26
remove a user, 7
replay, 31
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report template wizard, 16
report templates, 15
reports, 47
delete, 18
graph, 18
headers and footers, 17
logos, 16
results, 18
restore load, 33
results (view all data), 32
results data export, 47
results display, 42
review results, 30

S

sampling rate, 43
saving library programs, 52
saving results, 77
set absolute zero, 33
setup menu, 25
sharp break, 67
specimen toolbar, 33
statistical averages, 42
stop button, 29
system, 9
system deflection compensation (SDC), 9

T

tare
load, 80
position, 80
test menu, 21
test programs, 52
test stand toolbar, 33
timeline, 30
tolerance band, 88
toolbars, 29
tools menu, 26
transmit, 91
triggers, data acquisition, 43

U

units of measurement, 37

V

variables, 52, 64
verified calculation, 85
verify result, 64

Z

zero displacement/angle, 33
zero load, 33
zoom, 30
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Mecmesin : a world leader in affordable force and torque testing solutions
Since 1977, Mecmesin has assisted thousands of companies achieve enhanced quality control in design and production.
The Mecmesin brand represents excellence in accuracy, build, service, and value. In production centres and
research labs worldwide, designers, engineers, operators, and quality managers endorse Mecmesin force and torque
testing systems for their high performance across countless applications.
www.mecmesin.com
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Canada
Chile
China
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Croatia
Czech Republic
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Latvia
Lebanon
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Russia
Saudi Arabia

Serbia
Singapore
Slovakia
Slovenia
South Africa
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Sweden
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Taiwan
Thailand
Tunisia
Turkey
UK
USA
Vietnam

The Mecmesin global distribution network guarantees your testing solution is rapidly delivered and
efficiently serviced, wherever you are.

Head Office
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Mecmesin Limited

Mecmesin France

Mecmesin GmbH

w: www.mecmesin.com

w : www.mecmesin.fr

w: www.mecmesin.de

e: sales@mecmesin.com

e: contact@mecmesin.fr

e: info@mecmesin.de

North America

Asia

China

Mecmesin Corporation

Mecmesin Asia Co. Ltd

Mecmesin (Shanghai) Pte Ltd

w: www.mecmesincorp.com

w: www.mecmesinasia.com

w: www.mecmesin.cn
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